[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building Emacs-cvs on Cygwin

From: Angelo Graziosi
Subject: Re: Building Emacs-cvs on Cygwin
Date: Wed, 27 Sep 2006 00:18:29 +0200 (MET DST)

On Tue, 26 Sep 2006, Eli Zaretskii wrote:

> It is strange that changing a directory has this effect, but here are
> a few possibilities to work around the problem.  All of the following
> possibilities assume you start from the `src' directory:
>  1) gdb ./emacs.exe
>  2) gdb /usr/local/emacs-22.0.50/bin/emacs.exe
>  3) cd /usr/local/emacs-22.0.50/bin
>     gdb ./emacs.exe
>     (gdb) source /tmp/emacs/.build/src/.gdbinit
> If none of the above helps get rid of the hang, try to edit the file
> src/.gdbinit so that it is left only with definitions of commands
> (each definition is a block that starts with "define" and ends with
> "end") and their documentation (blocks that start with "document"),
> and remove everything else.

I will try your suggestions.

In any case there are other strange things. 

This morning (20060926 about 10:00 am) I have downloaded a new CVS source
of Emacs and have made e new build using the debug options we discussed
(CFLAGS='-ggdb -gdwarf-2 -g3 -O2'). Then I have installed
(prefix=/usr/local/emacs-22.0.50) it.

Obviously it does not work in the build dir but I can start it as usually
with an adeguate link

$ emacs-cvs & 

(/usr/local/bin/emacs-cvs -> /usr/local/emacs-22.0.50/bin/emacs.exe)

I have worked with it without problem, also with tool-bar On! I haven't
observed any crash. 

Seeing this i decided to make a new build without debug options
(CFLAGS='-O2')...installed etc... :

$ emacs-cvs &

works only if 'cd /usr/local'. If it is given in any other directory Emacs
core dumps!

> Interesting.  So without the tool bar it never crashes, no matter how
> long you leave it?

All the time (hours) I worked with it I haven't seen any crash.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]