[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: unicode-2 branch segfaulting on MacOS X?

From: Geoffrey Alan Washburn
Subject: Re: unicode-2 branch segfaulting on MacOS X?
Date: Wed, 08 Nov 2006 14:23:52 -0500
User-agent: Thunderbird 2.0b1pre (X11/20061108)

Kenichi Handa wrote:
Sorry for the late response on this matter.

In article <address@hidden>, Geoffrey Alan Washburn <address@hidden> writes:

Yes, doing the same worked for me. At least with regards to 'fc-list'. The latest emacs-unicode-2 (at least as of yesterday morning) was still not seeing the width attribute even though 'fc-list' now does. However, thinking about it now, it is quite likely that I have multiple versions of 'fc-list' installed on my computer, so maybe I should query them all to see if somehow the fontconfig library emacs is being linked against isn't still confused.

Please check which libfontconfig is used by emacs and
fc-list.  Does this work on Mac OS?

% ldd THE_ABSOLUTE_PATH_OF_EMACS_BINARY | grep fontconfig
% ldd THE_ABSOLUTE_PATH_OF_FC_LIST_BINARY | grep fontconfig

Alas MacOS X doesn't have something exactly equivalent to ldd (or I haven't been able to figure it out). There are some environment variables that can be set to print out what dynamic libraries it loads. As I mentioned in my other e-mail I have figured out that it was indeed a problem with emacs linking against Apple's X11 libraries rather the Darwin Ports version of fontconfig.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]