[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems with the url package on w32?

From: Lennart Borgman
Subject: Re: Problems with the url package on w32?
Date: Wed, 20 Dec 2006 00:45:11 +0100
User-agent: Thunderbird (Windows/20061025)

Kim F. Storm wrote:
address@hidden (Kim F. Storm) writes:

If :nowait t doesn't work on Windoze,
(featurep 'make-network-process '(:nowait t)) should return nil.
But why doesn't it work on Windoze?  Could someone please investigate it?

If this is a general problem, BROKEN_NON_BLOCKING_CONNECT should
be defined in window...

Would someone please check if this patch gives "good" results on Windows,
that is, make
  (featurep 'make-network-process '(:nowait t))
return nil, and not have any other bad effects on network connections.

*** ms-w32.h    15 Dec 2006 01:26:24 +0100      1.41
--- ms-w32.h    19 Dec 2006 16:45:18 +0100      
*** 137,142 ****
--- 137,147 ----
#define HAVE_SOCKETS 1 + /* But our select implementation doesn't allow us to make non-blocking
+    connects.  So until that is fixed, this is necessary:  */
+ + #define BROKEN_NON_BLOCKING_CONNECT 1 + /* Define this symbol if your system has the functions bcopy, etc. */ #define BSTRING
I tried to test, but I see Juanma has already done that now. Good.

However I noticed another very strange thing. I just tried to appy the patch with ediff-patch, using gnuwin32 binaries. It just hangs. Or rather patch seems to loop.

   emacs -Q (latest binaries built after pretest release today)
   C-x C-f .... ms-w32.h
   C-x C-f .... the-patch.diff
   M-x ediff-patch-buffers
   (answers with the default, ie the buffers from above)

Well, I was wrong... - after 5 min the patch was ready ... 3GHz, everything else runs fine...

There seem to be a bug here on some level. Has anyone else seen this?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]