[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Should libXt-devel be required to build Emacs?

From: Jan Djärv
Subject: Re: Should libXt-devel be required to build Emacs?
Date: Fri, 22 Dec 2006 08:43:37 +0100
User-agent: Thunderbird (X11/20061107)

Chong Yidong skrev:
Richard Stallman <address@hidden> writes:

    There's a problem with this: Autoconf 2.61 was only released in
    November this year, and it requires a new version of M4 (1.4.8), which
    in turn requires a new libc6.  Most existing GNU/Linux distributions
    won't have these packages (at least in their "stable" branches).

That's not so bad.  Most users don't need to rebuild the configure
file, so they won't have a problem.

However, we could ask the Autoconf developers to release a patched
version 2.59.1 which fixes this bug and doesn't require a new M4.

On the other hand, most users don't compile Emacs at all; they use
pre-packaged binaries; those that do compile Emacs can surely install

I think one of the goals of Emacs is that an ordinary user shall be able to compile and run a version for him/herself. An ordinary user can't install libXt-dev.

        Jan D.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]