[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

repost of 'make bootstrap' problem (was: make bootstrap fails from fresh

From: Ted Zlatanov
Subject: repost of 'make bootstrap' problem (was: make bootstrap fails from fresh CVS checkout)
Date: Mon, 31 Dec 2007 14:57:35 -0600
User-agent: Gnus/5.110007 (No Gnus v0.7) Emacs/22.1 (gnu/linux)

Reposting, also see message IDs <address@hidden> and
<address@hidden> for the original reports with full error
logs but this should be enough.  The error thrown is in the fileio.c
test I reference below.  I am top-posting since the below is just a log
of my reports, not a discussion.


On Fri, 14 Dec 2007 14:52:48 -0600 Ted Zlatanov <address@hidden> wrote: 

TZ> Further investigation:
TZ> I traced the error to fileio.c:3867:

TZ> if (XINT (end) != st.st_size
TZ>     || ((int) st.st_size * 4) / 4 != st.st_size)
TZ>   /* extra parameters added by me */
TZ>   error ("Maximum buffer size exceeded: XINT(end)=%d, st.st_size=%d", 
XINT(end), st.st_size);

TZ> This shows that XINT(end) and st.st_size are both 0, by the way.  This
TZ> agrees with my observation (see the original message) that no data is
TZ> read from the file that's being loaded before the maximum buffer size is
TZ> exceeded.

TZ> If I comment out that check, the compilation proceeds until:

TZ> Dumping under names emacs and emacs-23.0.50
TZ> emacs: Can't allocate buffer for /home/tzz/source/emacs/src/temacs

TZ> in unexelf.c, line 721.  I can't avoid that error so I'm unable to build 

TZ> This is under GCC 4.1.3 on Ubuntu:

TZ> Using built-in specs.
TZ> Target: i486-linux-gnu
TZ> Configured with: ../src/configure -v 
--enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr 
--enable-shared --with-system-zlib --libexecdir=/usr/lib 
--without-included-gettext --enable-threads=posix --enable-nls 
--with-gxx-include-dir=/usr/include/c++/4.1.3 --program-suffix=-4.1 
--enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug 
--enable-mpfr --enable-checking=release i486-linux-gnu
TZ> Thread model: posix
TZ> gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)

TZ> I also tried GCC 3.4 with the same result, in case the 4.1.3 prerelease
TZ> was a problem.  The error was exactly the same.

TZ> It's been almost a month since I reported this problem; I'd love to
TZ> figure out the cause.  Is anyone willing to help?  My C knowledge is
TZ> insufficient to figure out what's happening.

TZ> Ted

TZ> On Fri, 30 Nov 2007 17:17:06 -0600 Ted Zlatanov <address@hidden> wrote: 

TZ> Is this known to be broken, or am I missing something obvious?
TZ> I am surprised a `make bootstrap' failure is happening on Ubuntu, but
TZ> even if the problem is not with Emacs itself, it certainly looks like it
TZ> (or a library interaction triggered by load-with-code-conversion) from
TZ> my investigation.

TZ> On Tue, 20 Nov 2007 14:35:46 -0600 Ted Zlatanov <address@hidden> wrote: 

TZ> The full log follows.  This is with a clean CVS checkout on a new
TZ> Ubuntu 7.10 install.

TZ> After looking at loadup.el, I see the problem starts with the lines:

TZ> (setq load-source-file-function 'load-with-code-conversion)
TZ> (load "files")

TZ> when I remove the load-source-file-function setq, the files.el code is
TZ> loaded fine.  The bootstrap fails later at international/utf-8.el
TZ> because it can't read a ? character, but if I have the setq the next
TZ> Lisp library loaded causes the buffer size error.

TZ> In addition, strace of the temacs process shows that no data is read()
TZ> from the .el file.  The error happens *before* which to me indicates
TZ> this is not a problem with the Lisp code.  I checked it anyhow, and
TZ> it's a clean checkout from CVS without corruption.  I suspect it's an
TZ> error at the C level but I don't know enough about the bootstrap
TZ> process to debug this.

TZ> I searched older discussions and didn't see this.  Sorry if it's an
TZ> obvious problem.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]