emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs 23.0.60.1 built today (11th feb 2008) crashes under Vista


From: Eric Lilja
Subject: Re: emacs 23.0.60.1 built today (11th feb 2008) crashes under Vista
Date: Thu, 14 Feb 2008 21:12:06 +0100
User-agent: Thunderbird 2.0.0.9 (Windows/20071031)

Eli Zaretskii wrote:
From: Eric Lilja <address@hidden>
Date: Thu, 14 Feb 2008 02:18:36 +0100

I am happy to report that Emacs does indeed not crash on Vista after reverting the changes to w32.c, using the method suggested by Juanma. Hopefully a proper fix (because I assume the changes I reverted have some purpose too) isn't too hard to do.

Could you please compile the program below and run it on Vista with
some file name (a name of any existing file) as a single argument?
Then please post here everything it prints.  That might give me enough
information to fix the code.

Thanks.


I had to comment out #include <tchar.h> to get it to compile under cygwin's gcc in mingw mode. Here's the output from both mingw and visual c++ 9:
mingw:
$ ./runme.exe source.c
source.c:
         dflt=0 owner=Administrat├Ěrer grp=None domain=mindcool-laptop use=4
         Ownr SID=S-1-5-32-544 0x1f01ff
         Grp  SID=S-1-5-21-2313625805-1149499212-3830963393-513 0x1201ff



vs9:
$ ./source.exe ../../source.c
../../source.c:
         dflt=0 owner=Administrat├Ěrer grp=None domain=mindcool-laptop use=4
         Ownr SID=S-1-5-32-544 0x1f01ff
         Grp  SID=S-1-5-21-2313625805-1149499212-3830963393-513 0x1201ff





reply via email to

[Prev in Thread] Current Thread [Next in Thread]