[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: interactive-p and called-interactively-p

From: Richard Stallman
Subject: Re: interactive-p and called-interactively-p
Date: Sun, 16 Aug 2009 17:23:02 -0400

    > It would have been far better to just add an optional argument to
    > `interactive-p' than to create a new, similarly named function.

    Agreed.  Any objection?

I object.  Two different names makes it easier to remember the
difference.  An argument would be harder to remember.

The name `called-interactively-p' is good because
it relates to the use of `interactive'.  The name `interactive-p'
is confusing because it does NOT relate.

Perhaps we should make the name `interactive-p' obsolete
and make a new name, `from-user-input-p'.  This will eliminate
the confusion completely.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]