[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Forcing reinstall in package.el

From: Tom Tromey
Subject: Re: Forcing reinstall in package.el
Date: Fri, 17 Dec 2010 07:17:51 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (gnu/linux)

>>>>> "Stefan" == Stefan Monnier <address@hidden> writes:

Tom> I think the current behavior is better.
Tom> Usually installing something that has the same or lesser version is a
Tom> user error.  Only a subset of users will actually want to
Tom> force-overwrite a package.

Stefan> I mostly agree, but also agree that reinstalling is an important case.
Stefan> Is there any reason prompting the user is not a good solution?

As long as the prompt is clear that this is probably not what you meant,
I guess it is ok.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]