[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: open-network-stream problems on W32

From: Ted Zlatanov
Subject: Re: open-network-stream problems on W32
Date: Mon, 02 May 2011 13:37:04 -0500
User-agent: Gnus/5.110018 (No Gnus v0.18) Emacs/24.0.50 (gnu/linux)

On Tue, 26 Apr 2011 22:34:51 -0600 Christoph Scholtes <address@hidden> wrote: 

CS> Receiving mail with Gnus works. However, sending mail does still not work.

CS> I get an SMTP protocol error (from *Messages* w/gnutls-log-level=1):

CS> Sending via mail...
CS> No STARTTLS program was available (tried 'gnutls-cli')
CS> 220 mx.google.com ESMTP h74sm253108yhm.11
CS> 250-mx.google.com at your service, [...]
CS> 250-SIZE 35882577
CS> 530 5.7.0 Must issue a STARTTLS command first. h74sm253108yhm.11
CS> 221 2.0.0 closing connection h74sm253108yhm.11
CS> smtpmail-send-it: Sending failed; SMTP protocol error

CS> Do you think this is related to GnuTLS?

It should Just Work; you're never hitting the GnuTLS code and
`smtpmail-send-it' is trying to use just the "gnutls-cli" command-line
utility.  `smtpmail-send-it' needs to be configured or fixed in code
(probably the former).

For me, I just

(setq smtpmail-starttls-credentials '(("mysmtpserver.com" 587 nil nil)))

and then put this line:

machine mysmtpserver.com login tzz password mypassword

in my ~/.authinfo.gpg.  But my configuration has many layers so the
above may need to be modified a bit and you need to dig into it or
submit a bug if it still fails.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]