[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: open-network-stream problems on W32

From: Ted Zlatanov
Subject: Re: open-network-stream problems on W32
Date: Thu, 05 May 2011 05:40:05 -0500
User-agent: Gnus/5.110016 (No Gnus v0.16) Emacs/24.0.50 (gnu/linux)

On Wed, 04 May 2011 21:47:32 -0600 Christoph Scholtes <address@hidden> wrote: 

CS> On 5/2/2011 12:37 PM, Ted Zlatanov wrote:
>> It should Just Work; you're never hitting the GnuTLS code and
>> `smtpmail-send-it' is trying to use just the "gnutls-cli" command-line
>> utility.  `smtpmail-send-it' needs to be configured or fixed in code
>> (probably the former).

CS> What do you mean by "you're never hitting the GnuTLS code"?

I made a mistake.  Lars will add GnuTLS STARTTLS support to smtpmail.el
and when he does, things will work wihout external binaries on any
platform with GnuTLS support.

CS> I have been doing some more testing and compared behavior of the
CS> latest Emacs trunk on Debian (Squeeze) and Windows 7. I am using the
CS> same configuration in both instances:

CS> (require 'smtpmail)
CS> (setq send-mail-function 'smtpmail-send-it
CS>       message-send-mail-function 'smtpmail-send-it
CS>       smtpmail-starttls-credentials '(("smtp.gmail.com" 587 nil nil))
CS>       smtpmail-auth-credentials (expand-file-name "~/.authinfo.gpg")
CS>       smtpmail-default-smtp-server "smtp.gmail.com"
CS>       smtpmail-smtp-server "smtp.gmail.com"
CS>       smtpmail-smtp-service 587
CS>       user-mail-address "address@hidden"
CS>       smtpmail-debug-info t)

Lars and I were just talking about reworking this, especially
`smtpmail-starttls-credentials', to use auth-source credentials
exclusively.  Stay tuned.

CS> On Debian, at first, I didn't have `gnutls-bin' installed, so it
CS> failed with the same error as on Windows ("SMTP protocol error", see
CS> my earlier post). I then installed `gnutls-bin' and then everything
CS> worked fine.
CS> On Windows, I noticed that it couldn't find `gnutls-cli' either so I
CS> added the directory with the executable to the Emacs path.
CS> while: Sending failed; SMTP protocol error

CS> Why is the behavior with the same configuration different on Windows
CS> than on GNU/Linux? For the record, I made sure that I am using the
CS> same GnuTLS version on Windows and GNU/Linux, v2.8.6.

I know for sure neither platform is using GnuTLS for you.  When Lars
updates smtpmail.el we can re-test, but meanwhile you can look at the
docs on the Emacs Wiki for configuring `gnutls-cli' on W32.  I don't use
W32 so I don't know what's breaking there.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]