[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fwd: [emacs-w3m:11603] Re: interactive-p obsolete

From: Andreas Röhler
Subject: Fwd: [emacs-w3m:11603] Re: interactive-p obsolete
Date: Wed, 06 Jul 2011 08:12:52 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; de; rv: Gecko/20110616 SUSE/3.1.11 Thunderbird/3.1.11


making `interactive-p' obsolete, does this change pay?

I'm in favour of keeping interactive-p, resp. undoing that change.



-------- Original-Nachricht --------
Betreff: [emacs-w3m:11603] Re: interactive-p obsolete
Datum: Wed, 06 Jul 2011 12:58:03 +0900
Von: Katsumi Yamaoka <address@hidden>
Antwort an: address@hidden, address@hidden
Organisation: Emacsen advocacy group
An: address@hidden
CC: address@hidden

In [emacs-w3m : No.11600] address@hidden wrote:
On (info "(emacs-w3m) Gnus") we are told to use
 (if (interactive-p)
  This function is obsolete since 23.2;
  use `called-interactively-p' instead.
Please update the paragraph and tell us what you used. Thanks.

We cannot use `called-interactively-p', otherwise emacs-w3m won't
work with old Emacsen.  Some Lisp packages, even in the Emacs trunk,
still use `interactive-p' for the same reason.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]