[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Proposal to improve the nomenclature of scrolling directions

From: Eli Zaretskii
Subject: Re: Proposal to improve the nomenclature of scrolling directions
Date: Wed, 07 Nov 2012 18:23:47 +0200

> From: "Drew Adams" <address@hidden>
> Date: Wed, 7 Nov 2012 07:17:52 -0800
> Cc: address@hidden, address@hidden, address@hidden
> > If PageDown is generally understood as the name for what C-v does, it
> > seems to me we could give that command the new alias `page-down' and
> > bind C-v to that.  Users would find it clear by reference to what
> > PageDown does in other programs.  The Emacs Manual use that 
> > name to document the command, but the existing name could remain
> > valid.
> Bad idea.  "page" in Emacs function and variable names has a meaning that
> revolves around the use of form-feed (^L) as a page delimiter.

Only veteran Emacs users know about that meaning of "page", and those
should have no problems with the current command names.  And anyway,
bringing up arguments from Emacs traditions flies in the face of this
thread's main premise, which is that it's bad to have Emacs traditions
contradict widespread conventions.

> That makes it easy to use `apropos' or completion (e.g. with
> substring matching) to show you such names.
> Co-opting "page" for this very different meaning (scrolling one screenful or
> some other amount) creates false positives, weakening this feature.

Then you must object to commands and variables that match "code-page"
and "codepage", which already show in significant numbers in
'apropos'.  But since we already have this other meaning of "page",
having yet a 3rd one should not be such a grave problem, IMO.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]