[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Emacs-diffs] /srv/bzr/emacs/trunk r112148: Added eshell-tramp modul

From: Aidan Gauland
Subject: Re: [Emacs-diffs] /srv/bzr/emacs/trunk r112148: Added eshell-tramp module
Date: Sat, 30 Mar 2013 16:14:16 +1300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.2 (gnu/linux)

Stefan Monnier <address@hidden> writes:

>>> That's not my experience.
>>> After
>>> M-: (defun eshell/cat (&rest args) (debug)) RET
>>> doing "cat ~/.cvsrc" does not show me ~/.cvsrc but jumps into the
>>> debugger, even though I have not touched eshell-complex-commands.
>> That would be because eshell/cat is already registered by em-unix
> I tried again with `partx' instead of `cat' and got the same result, yet
> `partx' does not appear in eshell's source code.

Oh... this is a problem, indeed.  I'll draw John Wiegley's attention to
this thread, and hopefully he can explain this.  I *thought* I knew how
this part of Eshell worked. :/


reply via email to

[Prev in Thread] Current Thread [Next in Thread]