[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Building Emacs from a new MinGW environment

From: Dani Moncayo
Subject: Building Emacs from a new MinGW environment
Date: Mon, 26 Aug 2013 20:38:23 +0200


today, I've noticed that the MinGW developers have recently released a
new graphical installation & setup tool: mingw-get-setup.exe [1].

I've tried it, and I've easily set up a brand new MinGW (+MSYS)
development environment.

Then, I've tried to build Emacs from the new environment (with the same
script I use these days).  The autogen & configure steps go well, but
"make bootstrap" fails here:

gcc  -std=gnu99 -DHAVE_CONFIG_H -I.
-I/c/MinGW/msys/1.0/home/dani/emacs/trunk/lib -I
../src -I/c/MinGW/msys/1.0/home/dani/emacs/trunk/src   -mtune=pentium4
G=1 -I/c/usr/include -DUSE_CRT_DLL=1 -I
nc    -O0 -g3 -MT gettimeofday.o -MD -MP -MF .deps/gettimeofday.Tpo -c
-o gettimeofd
ay.o /c/MinGW/msys/1.0/home/dani/emacs/trunk/lib/gettimeofday.c
error: conflicting
 types for 'gettimeofday'
In file included from
c:/MinGW/msys/1.0/home/dani/emacs/trunk/nt/inc/sys/time.h:45:5: note:
previous decla
ration of 'gettimeofday' was here
make[3]: *** [gettimeofday.o] Error 1
make[3]: Leaving directory `/c/MinGW/msys/1.0/home/dani/emacs/build/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/c/MinGW/msys/1.0/home/dani/emacs/build/lib'
make[1]: *** [lib] Error 2
make[1]: Leaving directory `/c/MinGW/msys/1.0/home/dani/emacs/build'
make: *** [bootstrap] Error 2

--- Footnotes ---

[1] Available at http://sourceforge.net/projects/mingw/files/Installer/

Dani Moncayo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]