[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building Emacs from a new MinGW environment

From: Eli Zaretskii
Subject: Re: Building Emacs from a new MinGW environment
Date: Wed, 18 Sep 2013 10:46:29 +0300

> Date: Tue, 17 Sep 2013 22:29:43 +0200
> From: Dani Moncayo <address@hidden>
> Cc: Emacs development discussions <address@hidden>
> > I don't understand where did the
> > C:/msys/home/d.moncayo.melgar/emacs/emacs.git/ directory come from?
> > Does directory by such name indeed exist on your disk, and Windows
> > (not MSYS) can find it?  Did you try this from a directory different
> > from where you made your previous trials?
> That directory is simply the root of my local Emacs source code tree.
> I guess that what confused you is the "d.moncayo.melgar" part, which
> was "dani" in previous messages.  Well, the difference is due that one
> is the desktop I use at work, and the other is my personal laptop.

Please make a point of telling this in the future.  I have no way of
knowing when you make such changes, and they add more confusion to
this already complicated issue.

> > If the directory exists, I don't understand the reason for these
> > failures:
> >
> >   /bin/makeinfo --force --enable-encoding -I 
> > C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref/../emacs -I 
> > C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref --no-split -o 
> > C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref/../../info/elisp.info
> >  C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref/elisp.texi
> >   C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref/elisp.texi:58: 
> > @include `emacsver.texi': No such file or directory.
> >
> > Is this some problem with the MSYS port of makeinfo, perhaps?
> I've always used the makeinfo that comes with MSYS, yes.  But that
> version have always worked fine for me.  This problem appears just
> when I try your proposed change in "configure.ac".

If you invoke the above command from the MSYS Bash prompt, does it
also fail in the same way?

> I've tried it again:  autogen.sh + msysconfig.sh + "make bootstrap",
> with this single change in my Emacs tree:
>   diff --git a/configure.ac b/configure.ac
>   index 86a5f30..cb8f6d6 100644
>   --- a/configure.ac
>   +++ b/configure.ac
>   @@ -443,6 +443,8 @@ case "${srcdir}" in
>      *  ) srcdir=`(cd "$srcdir"; pwd)` ;;
>    esac
>   +test "$MSYSTEM" = "MINGW32" && srcdir=`(cd "$srcdir"; pwd -W)`
>   +
>    ### Canonicalize the configuration name.
> The result in my laptop seems to be the same than in my office
> desktop: autogen ok, configure ok, but bootstrap failure  (new logfile
> attached).

What about this variant:

 test "$MSYSTEM" = "MINGW32" && srcdir=`(cd "$srcdir"; pwd -W | sed -e 

It should produce srcdir in the /d/foo/bar format.

> Perhaps you could try this yourself.

Sorry, I don't have time for this.  If the above still does not work,
then for now, building under the MSYS root will be unsupported, until
someone figures a way of making it work and submits the necessary

reply via email to

[Prev in Thread] Current Thread [Next in Thread]