[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building Emacs from a new MinGW environment

From: Dani Moncayo
Subject: Re: Building Emacs from a new MinGW environment
Date: Wed, 18 Sep 2013 11:32:09 +0200

> Please make a point of telling this in the future.  I have no way of
> knowing when you make such changes, and they add more confusion to
> this already complicated issue.

I'm sorry.  I thought the change in the user name will not confuse you.

>> > If the directory exists, I don't understand the reason for these
>> > failures:
>> >
>> >   /bin/makeinfo --force --enable-encoding -I 
>> > C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref/../emacs -I 
>> > C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref --no-split -o 
>> > C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref/../../info/elisp.info
>> >  C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref/elisp.texi
>> >   C:/msys/home/d.moncayo.melgar/emacs/emacs.git/doc/lispref/elisp.texi:58: 
>> > @include `emacsver.texi': No such file or directory.
>> >
>> > Is this some problem with the MSYS port of makeinfo, perhaps?
>> I've always used the makeinfo that comes with MSYS, yes.  But that
>> version have always worked fine for me.  This problem appears just
>> when I try your proposed change in "configure.ac".
> If you invoke the above command from the MSYS Bash prompt, does it
> also fail in the same way?

Yes, it fails the same way.  I'm attaching the output I get from that
command, when invoked directly from bash.

>> I've tried it again:  autogen.sh + msysconfig.sh + "make bootstrap",
>> with this single change in my Emacs tree:
>>   diff --git a/configure.ac b/configure.ac
>>   index 86a5f30..cb8f6d6 100644
>>   --- a/configure.ac
>>   +++ b/configure.ac
>>   @@ -443,6 +443,8 @@ case "${srcdir}" in
>>      *  ) srcdir=`(cd "$srcdir"; pwd)` ;;
>>    esac
>>   +test "$MSYSTEM" = "MINGW32" && srcdir=`(cd "$srcdir"; pwd -W)`
>>   +
>>    ### Canonicalize the configuration name.
>> The result in my laptop seems to be the same than in my office
>> desktop: autogen ok, configure ok, but bootstrap failure  (new logfile
>> attached).
> What about this variant:
>  test "$MSYSTEM" = "MINGW32" && srcdir=`(cd "$srcdir"; pwd -W | sed -e 
> 's,^\([A-Za-z]\):,/\1,')`
> It should produce srcdir in the /d/foo/bar format.

It didn't produce that format, because the configure script generated
by "autogen.sh" a slightly different version of that line: the square
brackets in "[A-Za-z]" were removed.

I managed to get the intended conversion with this line in "configure.ac":

  test "$MSYSTEM" = "MINGW32" && srcdir=`(cd "$srcdir"; pwd -W | sed
-e 's,^\([[A-Za-z]]\):,/\1,')`

With that change, now the only problems remaining are the crashes I
get much later in the bootstraping, when Emacs compiles certain Elisp

I already saw these severals days ago when I invoked msysconfig like this:
  (environment vars)
/c/msys/home/dani/emacs/emacs.git/nt/msysconfig.sh --enable-checking

Perhaps these crashes are due to a different problem.

I'm attaching:
* The "config.log" file.
* The summary of the configure script.
* The output of "make bootstrap".

Dani Moncayo

Attachment: attachments.zip
Description: Zip archive

reply via email to

[Prev in Thread] Current Thread [Next in Thread]