[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Fri, 04 Apr 2014 10:41:37 +0200
Gnus/5.13 (Gnus v5.13) Emacs/24.4.50 (gnu/linux)
Paul Eggert <address@hidden> writes:
> Eli Zaretskii wrote:
>> I suggested ALEN because we have AREF and ASIZE. Maybe AELTS or
>> ALENGTH would be better.
> The most common name for this macro in other projects is probably
> ARRAY_SIZE. That's what's in libiberty, for example. There are other
> names (ARRAY_CARDINALITY, SIZEOF) but ARRAY_SIZE seems to be more
I see it in the Git codebase. I don't have the Linux source available
at the moment, but since it is involved with the same kind of crowd,
I consider it likely that they use it as well.
Even in Emacs, we have OBARRAY_SIZE defined as a member count rather
than a byte count (there is no other "ARRAY_SIZE" string in Emacs so
Can't be that confusing to people.