[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: strange error from global-ede-mode

From: Stephen Leake
Subject: Re: strange error from global-ede-mode
Date: Fri, 11 Sep 2015 14:47:48 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (windows-nt)

Stephen Leake <address@hidden> writes:

> Stefan Monnier <address@hidden> writes:
>>> Enabling debug-on-error does not catch the error.
>> Have you tried debug-on-signal?
> No help.
>> If that still doesn't help, try running in GDB, then putting a break
>> point on maybe_call_debugger and then look at "xbacktrace".
> Also no help.
> I traced thru x-create-frame in gdb; the error occurs in
> initialize_frame_menubar.
> I get the same error message by activating the menubar with F10 in the
> files.el buffer in the initial fraem. But debug-on-error is still no
> help. So I'm off to study the menu init code; I'm guessing it's
> something in the EDE "Development" menu.

Found the problem; it's from ede-project-forms-menu, operating on the
EDE Emacs project.

The code walks up the class hierarchy, collecting the class default
value from the menu slot at each level.

To reproduce the error from Emacs master -Q:

(require 'ede/emacs)
(setq prj
    :name "Emacs"
    :version "25.0.50"
    :directory "/Projects/emacs/master"
    :file "/Projects/emacs/master/src/emacs.c"))

(setq class (eieio-object-class prj))
(oref-default class menu) ;; no error
(setq parent (eieio-class-parent class))
(oref-default parent menu) ;; error

The error is from:

    (cl-check-type obj (or eieio-object class))

I'm not familiar enough with cl stuff to figure out what's wrong here.

-- Stephe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]