[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH PING] Honor 'SOURCE_DATE_EPOCH' when generating autoloads.

From: Philipp Stephani
Subject: Re: [PATCH PING] Honor 'SOURCE_DATE_EPOCH' when generating autoloads.
Date: Wed, 23 Dec 2015 16:52:08 +0000

Eli Zaretskii <address@hidden> schrieb am Mi., 23. Dez. 2015 um 17:38 Uhr:
> From: Philipp Stephani <address@hidden>
> Date: Wed, 23 Dec 2015 16:01:30 +0000
> OK, here's a patch.

Thanks.  A few minor comments.

> +AC_ARG_ENABLE(deterministic-dump,
> +[AS_HELP_STRING([--enable-deterministic-dump],
> +                [Make dumping deterministic by removing system-specific
> +                information from the dump, such as host names and
> +                timestamps.])])

I'd prefer calling this "deterministic-build", so that we could use it
to solve any other similar problems unrelated to dumping.  Maybe even

I think we have two categories of builds here:
- Builds that get executed when running 'make' in the Emacs directory. This includes dumping and byte compilation of code bundled with Emacs.
- Builds that get executed by running an initialized Emacs binary, likely on a different machine. This includes e.g. byte compilation of third-party libraries.
I think these two categories are separate enough to have two different variables. This patch only addresses the first category, therefore I didn't want to use the generic term "build", but "dump" is also not quite right. Do we have a proper term for the first category? "bootstrap"? "emacs-build"?

(If we do change the option, we should also change the name of the
variable and the cpp symbol.)

> +(defconst emacs-build-system
> +  (if deterministic-dump "unknown" (system-name))
>    "Name of the system on which Emacs was built.")

Can we find a better string, like "elided" or "undisclosed"?
"Unknown" sounds too self-derogatory.

Sure, 'elided' is fine.

> +  DEFVAR_BOOL ("deterministic-dump", Vdeterministic_dump,
> +    doc: /* If t, attempt to make dumping deterministic by avoiding

I think the usual style is "If non-nil".


> +sources of nondeterminism such as absolute paths, the hostname, or

GNU coding standards frown on using "path" for anything that isn't
PATH-style list of directories.  Please use "file name" instead.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]