[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Emacs can't reach dx.doi.org?

From: Clément Pit--Claudel
Subject: Emacs can't reach dx.doi.org?
Date: Fri, 18 Mar 2016 19:05:06 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.6.0

Hi all,

I'm having a surprising issue, whereby Emacs -Q sometimes doesn't seem to be 
able to reach dx.doi.org; other websites work fine, but for that particular one 
the network process stays in "connect" state for a while, then goes to "failed" 
state. I'm pretty sure it worked a few days ago, and it has worked 
intermittently today. I'm on the latest pretest.

Before opening a bug report, I'd like to make sure that I'm not doing anything 
silly: I'm trying to open http://dx.doi.org/10.1016/s0262-4079(08)62292-7 ; 
with eww, I get "Loading http://dx.doi.org/10.1016/s0262-4079(08)62292-7...". 

   (lambda (&rest args) (message "args: %S" args)))

I get 'Contacting host: dx.doi.org:80', and nothing. After a few calls 
list-processes shows this:

dx.doi.org      failed   *http dx.do... --           (network connection to 
dx.doi.org<1>   failed   *http dx.do... --           (network connection to 
dx.doi.org<2>   connect  *http dx.do... --           (network connection to 

Setting url-debug doesn't seem to make any difference.

Using curl to get the same page works fine. I tried to have a look in 
wireshark, but it seems that Emacs never opens a connection; at least, I can't 
see anything.

Does this ring a bell for anyone? Can anyone reproduce it? I can't always 
reproduce it myself; it happens for a while, then it goes away. In all cases 
the website is still reachable with curl.


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]