[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: New Package for GNU ELPA

From: Ian Dunn
Subject: RE: New Package for GNU ELPA
Date: Tue, 24 May 2016 19:37:40 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (gnu/linux)

On 2016-05-22, Drew Adams wrote:

> If this is a package in GNU ELPA, shouldn't its thingies have a
> package prefix?
> IOW, shouldn't `define(-mode)-hook-helper' be called something like
> `hkhlp-define(-mode)-hook-helper'?
> I'm not saying it should, as the rules for GNU ELPA packages are not
> clear to me.  But if its packages follow the general rule then they
> should have a prefix, no?

According to the "Emacs Lisp Coding Conventions" section of the "GNU
Emacs Lisp Reference Manual":

"Constructs that define a function or variable should be macros, not
functions, and their names should start with ‘define-’."

That might make sense for `remove-hook-helper', though.

Ian Dunn

reply via email to

[Prev in Thread] Current Thread [Next in Thread]