[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: New Package for GNU ELPA

From: Drew Adams
Subject: RE: New Package for GNU ELPA
Date: Tue, 24 May 2016 17:16:52 -0700 (PDT)

> > shouldn't `define(-mode)-hook-helper' be called something like
> > `hkhlp-define(-mode)-hook-helper'?
> According to the "Emacs Lisp Coding Conventions" section of the "GNU
> Emacs Lisp Reference Manual":
> "Constructs that define a function or variable should be macros, not
> functions, and their names should start with ‘define-’."

Touche. ;-)

(That exception was not there originally, BTW.  But it's fine by me.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]