[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fixing a bug on Tramp

From: Michael Albinus
Subject: Re: Fixing a bug on Tramp
Date: Tue, 14 Aug 2018 17:23:23 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Justin Joseph Kaipada <address@hidden> writes:

Hi Justin,

> Your speculation was right, running echo \"`uname -sr`\" on /bin/sh
> does not return with quotes. I tried setting tramp-encoding-shell and
> explicit-shell-file-name both to "/bin/bash" but I still get the same
> error.

Well, first we need to know whether bash would help. If you are on the
remote machine, and have started /bin/bash, does

# echo \"`uname -sr`\"

print the apostrophes?

If yes, pls eval the following form in your Emacs:

--8<---------------cut here---------------start------------->8---
  `(,(regexp-quote "torolabw.canlab.ibm.com") "remote-shell" "/bin/bash"))
--8<---------------cut here---------------end--------------->8---

Additionally, you might call "M-x tramp-cleanup-all-connections" in
order to flush the caches.

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]