[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fixing a bug on Tramp

From: Michael Albinus
Subject: Re: Fixing a bug on Tramp
Date: Wed, 29 Aug 2018 10:30:42 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Justin Joseph Kaipada <address@hidden> writes:

Hi Justin,

>> What if you try LC_ALL=En_US.UTF-8 (w/o the suffix)?
> $ export LC_ALL=En_US.UTF-8
> bash: warning: setlocale: LC_ALL: cannot change locale (En_US.UTF-8):
> EDC5129I No such file or directory.
> So that is not supported at all. Z/OS does not even think its an
> encoding.

I'm running out of ideas. Tramp is based on using utf8 on the remote
side, so I fear that, even if we solve the problem at hand, we will
enter the next trap, soon.

> I still don't understand why tramp is changing the encoding after the
> first echo with the uname worked thou, I tried disable those line
> where it change the encoding and it still errors out.

So it hasn't anything to do with this.

If there were any public Z/OS machine on the world, I could run my
tests. Unfortunately, I do not own such a machine. Sorry.

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]