[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Recent changes incorrectly calculate font size within daemon mode

From: Paul Eggert
Subject: Re: Recent changes incorrectly calculate font size within daemon mode
Date: Thu, 30 Aug 2018 10:21:20 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.9.1

Yuri D'Elia wrote:
On Thu, Aug 30 2018, Paul Eggert wrote:
Quite possibly, yes. What platform are you running on? And can you tell
me exactly how you set fontconfig/Xres? I am having trouble reproducing
the problem.

This is on debian unstable, X11 lucid build (--without-gsettings

After looking at my config, I think the only part that matters is this:

$ xrdb -q | grep dpi
Xft.dpi:        95

DPI values are also set explicitly via xrandr --output [all outputs]
--dpi 95 to be consistent, but AFAIK emacs always ignored xrandr values.

Other settings are correctly applied, so it's the font scaling which has
some issues when emacs is started via --daemon (both
--fg-daemon/--bg-daemon result in the same behavior).

I'm not seeing the problem on my Ubuntu 18.04 desktop. I configured Emacs master this way:

./configure --enable-gcc-warnings --without-gsettings --with-x-toolkit=lucid

And I ran it this way:

src/emacs -Q --fg-daemon
lib-src/emacsclient -c

I also tried --fg-daemon and couldn't reproduce it that way either.

What is your native screen resolution and how are you setting your font scaling factor? I used gnome-tweaks to set my font scaling factor to 1.30. My xrdb output says:

$ xrdb -q | grep dpi
Xft.dpi:        124.7998046875

My native screen resolution is 1920x1200 and my native Xft.dpi is 96.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]