[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [feature/rcirc-update] Reconnects don't seem to work anymore

From: Tassilo Horn
Subject: Re: [feature/rcirc-update] Reconnects don't seem to work anymore
Date: Tue, 15 Jun 2021 20:39:08 +0200
User-agent: mu4e 1.5.13; emacs 28.0.50

Philip Kaludercic <philipk@posteo.net> writes:

Hi Philip,

>> Tassilo Horn <tsdh@gnu.org> writes:
>>> I'm now restarting emacs.  The next time I get a disconnect, I'll try
>>> /reconnect instead.
>> I got disconnected from freenode, and this time I've tried /reconnect
>> instead of `M-x rcirc RET'.  However, that reconnected to the server but
>> again all channel buffers still show rcirc:disconnected.  The
>> `rcirc-buffer-alist' in the server buffer for freenode is still
>> populated with the right buffers as previously.
> I am still not able to consistently reproduce this issue. Just to be
> sure, what commit are you on?

I'm on fd96e3a0d9.  I've just pulled again and 8 new commits appeared,
the oldest being from 5 days ago.  I'm pretty confident I've pulled at
least every other day in order to see if there's something new.  Did you
forget to push?

Anyway, I've updated to the current branch HEAD and restarted my

>> 06:58 -*.freenode.net- *** You are connected to chat.freenode.net using TLS
>>                        (SSL) cipher 'TLSv1.3-TLS_AES_256_GCM_SHA384'
>> 06:58 !!! "@msgid=446~1623712485~22272;inspircd.org/service;inspircd.org/bot
>>           :NickServ!services@services.freenode.net NOTICE tsdh :Nick tsdh
>>           isn't registered." (wrong-type-argument arrayp nil)
> From your other message, it seems like this is specificity related to
> freenode, right?

Yes, only freenode and only since today with no changes on rcirc in the
meantime.  When I do

    /msg nickserv help

in the *chat.freenode.org* buffer, I get the response

    20:42 *** 401 n No such nick

and in the buffer N@chat.freenode.org there is

    20:42 <tsdh> ickserv help

So now that user N has my nickserv password and I can't change it
because freenode seems broken...

I've asked on #help and the answers are:

  1. I should use "/ns IDENTIFY password" instead of "/msg NickServ".
  2. I should look into using SASL for identificiation.
  3. "/quote nickserv identify password" also gives an
     (wrong-type-argument arrayp nil) error but finally told be that
     tsdh is not a registered nick.

And then I was told that the original freenode with its user database is
now on classic.freenode.org and irc.freenode.org is something set up
completely anew without the previous data...

I was also told that "/msg foobar text" only works if the user foobar is
online.  If not, it'll select the first online user whose nick is a
prefix of foobar and send the remainder as message.  (That's why the
user N received my NickServ IDENTIFY message.)

I've just tried "/msg totototoXXX this is a test" on libera.chat and
it's the same there.  The user t received a message "otototoXXX this is
a test". :-(

So it would make sense that rcirc checked if there is an online user
NickServ before sending the IDENTIFY message to prevent password leakage
to random users as has happended to me.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]