[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Moving kbd to subr.el

From: Stefan Monnier
Subject: Re: Moving kbd to subr.el
Date: Tue, 19 Oct 2021 10:45:46 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

> kbd-define
> kbd-define-map

Since we're in the bikeshedding part of this, let me throw some ideas:

- The name `define-key` might be tolerable because it "defines" the behavior of
  a given key, but I find it shouldn't say "define" but rather something
  like "set" or "put" since it behaves much more like `setq`, `aset`,
  `put`, `puthash`, ...

- I really don't like `define-keymap` because "define" usually gives
  a definition to a name, but here there's no name.  I'd prefer
  something that says "make" or "create", or even just `keymap` (in the
  tradition of reusing a type/class name as the name of the function
  that constructs objects of this type).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]