[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [External] : [emacs bookmark.el] Sorting by last set

From: Manuel Giraud
Subject: Re: [External] : [emacs bookmark.el] Sorting by last set
Date: Sun, 05 Jun 2022 22:53:11 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/29.0.50 (berkeley-unix)

Drew Adams <drew.adams@oracle.com> writes:

> I can't speak to whatever behavior you've
> currently implemented.
> But why would _setting_ a bookmark be the only
> modification that you want reflected in such a
> property?
> And does this "setting" include RE-setting or
> just initial setting (which I guess is about
> the same as creating)?


It works for this "setting" and RE-"setting" but not for annotations
change nor renaming. Maybe "set" is not a good name. Why not "placed"?
As a bookmark in book?


> But even just an annotation edit is a change,
> and it might well be significant for a user.
> Let's not belittle modification other than
> setting.

You're right and that is why it should be clear that this behaviour is
for "placing" the bookmark only. Maybe other kind of modified field
could be add later... or the current behaviour changed along with its

> If you're going to introduce a last-modified
> time property of some sort, I'd suggest that,
> by default at least, it be updated for any
> change to the bookmark - maybe even automatic
> repositioning.
> But including automatic repositioning could
> be a user decision (e.g., a user option, off
> by default.  Better is to have a (list value)
> option that can cover all predefined kinds of
> modification.

A fully customizable "last-modified" sorting might be a bit too much for
bookmark.el but trying to gather many modifications under one umbrella
could be better than just "placed". What others think?

For my usage, I prefer the "placed only" behaviour.


>> Why not... but we have to settle for good symbol names. I propose
>> 'last-created (as nil) and 'alphabetical (as t).
> Would you please use `created', the same field
> name that Bookmark+ uses?  Occam's razor says
> not to complicate things gratuitously.  Why
> not use the same name, for the same thing?
> There's only one creation of a given bookmark.
> It makes no sense to talk of a "last" creation
> time.

Yes of course. But in what I proposed, 'created would only be a possible
symbol for `bookmark-sort-flag' (or new name), nothing more.

>> I prefer `bookmark-sort'.
> Please see what I wrote in my previous message,
> if for no reason other than it provides useful
> food for thought.

I've read it. But I think that for the bundled bookmark.el having a
predefined set of sorting functions could be enough.

As for composability of sorting, I think keeping it to "one at a time"
could also be enough. And for users that need more there is Bookmark+

Best regards,
Manuel Giraud

reply via email to

[Prev in Thread] Current Thread [Next in Thread]