[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Orgmode] Makefile fix?

From: Miguel A. Figueroa-Villanueva
Subject: Re: [Orgmode] Makefile fix?
Date: Tue, 10 Jul 2007 23:58:44 -0400

Hello Carsten,

Yep, I guess I missed that point... I tried your idea below, but it
didn't work on my end. If it works then maybe it is a more robust
solution. However, the following code worked for me for emacs and
xemacs. Note that it assumes that the EMACS variable is either emacs
or xemacs.

# Name of your emacs binary

# Using emacs in batch mode.
ifeq ($(EMACS),xemacs)
 BATCH=$(EMACS) -batch -q -l $(lispdir)/noutline
 BATCH=$(EMACS) -batch -q

Hope this helps.


On 7/10/07, Carsten Dominik <address@hidden> wrote:
You are right, this would be better.  However, the same line
then would not work for Emacs, so we need something still
better.  Maybe something like

BATCH=$(EMACS) -batch -q
        -eval '(add-to-list 'load-path "$(lispdir)")'

but that is still difficult with all the quoting and escaping of
quoting.  Does anyone here know how to make this work?

- Carsten

On Jul 8, 2007, at 20:21, Miguel A. Figueroa-Villanueva wrote:

> Hello Everyone,
> First of all thanks for creating such a great tool!! Kudos Dominik!!
> Now, I updated orgmode and had minor problems with the installation.
> The problem was because I use XEmacs so it requires the noutline.el
> installed. Since I edited the following entries:
> # Where local software is found
> prefix=/root_dir/svn/usr/local
> # Where local lisp files go.
> lispdir = $(prefix)/share/emacs
> when I type 'make install-noutline' it installs it in $(lispdir),
> which is what I wanted (i.e., not in the standard lisp directory). The
> $(lispdir) is of course added to the load-path in my init.el, but for
> the remaining compilation of org.el it won't know to look for
> noutline.el in there.
> Now, since we need noutline.el to compile org.el for XEmacs and we
> just installed it in $(lispdir), shouldn't the following line:
> BATCH=$(EMACS) -batch -q
> read like this instead:
> BATCH=$(EMACS) -batch -q -l $(lispdir)/noutline
> That is where my problem was and by making the change above it was
> fixed. Notice that if $(lispdir) is set to the standard lisp directory
> then the problem won't arise.
> Well, I hope that this helps in case others encounter the same problem.
> Thanks again,
> --Miguel
> _______________________________________________
> Emacs-orgmode mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/emacs-orgmode

Carsten Dominik
Sterrenkundig Instituut "Anton Pannekoek"
Universiteit van Amsterdam
Kruislaan 403
NL-1098SJ Amsterdam
phone: +31 20 525 7477

reply via email to

[Prev in Thread] Current Thread [Next in Thread]