[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] org unavailable in ELPA package manager

From: Jambunathan K
Subject: Re: [O] org unavailable in ELPA package manager
Date: Tue, 26 Jul 2011 19:26:08 +0530
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (windows-nt)

Max Roberts-Zirker <address@hidden> writes:

> Thanks for sticking with me Jambunathan,
> C-h v package-archives RET reports no match also, though there do
> appear to be commands: package-archive-base,
> package-archive-upload-base, package-archive-version, and
> package-archive-contents.

C-h v package-archives MUST report something like as below.

(("gnu" . "http://elpa.gnu.org/packages/";))

> Also, when I run M-x package-list-packages, it connects me to the 
> tromey.com site and provides a list of available packages (INCLUDING
> ORG in red, which I assume means it is already installed.)

You aren't following the instructions correctly.

| If you are using package.el from tromey.com then you need to delete it
| from load-path.

Use M-x locate-library RET package RET

and delete those package.el and package.elc files before installing the
package.el file that the FAQ points to.

Jambunathan K.

> Max...
> P.S. The ~/elisp file was successfully copied, and I'm no longer
> getting a load-path error when I start emacs, so I think that solved
> something.  Thanks.
> On Tue, Jul 26, 2011 at 9:27 AM, Jambunathan K <
> address@hidden> wrote:
>     > - I just successfully upgraded to Org-Mode version 7.6 using
>     the "How
>     > do I install Org-mode from a ELPA-compatible tarball?" section
>     from
>     > http://orgmode.org/worg/org-faq.html#installing-elpa
>     Good. But downloading by hand is kind of a pain.
>     > However, I'm not sure why this should have worked, since
>     >
>     > - M-x list-packages RET displays "[No match]" in the bottom
>     bar.
>     What does C-h v package-archives report?
>     > I'm not sure what to do with http://repo.or.cz/w/emacs.git/
>     blob_plain
>     > /1a0a666f941c99882093d7bd08ced15033bc3f0c:/lisp/emacs-lisp/
>     package.el
>     > but I assume since I'm now running Org-Mode 7.6 it is no longer
>     > necessary.
>     If you want to use package manager with emacs-23 this step is
>     necessary. Copy it to "~/elisp" and follow step 2.
>     Jambunathan K.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]