[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] Bug: org-babel-tangle error. org-babel-get-header undefined [8.3

From: Nick Dokos
Subject: Re: [O] Bug: org-babel-tangle error. org-babel-get-header undefined [8.3.2 (release_8.3.2-317-gbd921f @ /home/swflint/.emacs.d/org-mode/lisp/)]
Date: Thu, 12 Nov 2015 14:06:07 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (gnu/linux)

"Samuel W. Flint" <address@hidden> writes:

> On Thu, November 12, 2015 11:36 am, Kyle Meyer wrote:
>> Hello,
>> address@hidden (Samuel W. Flint) writes:
>>> Hey all!
>>> In an attempt to keep my config file organized, I've been using org.  As
>>> of a fairly recent update, when I tangle the document (C-c C-v C-t), I
>>> get the following error "Symbol's function definition is void:
>>> org-babel-get-header".  I have no idea why this is happening.  I've
>>> attached a backtrace.
>>> TIA,
>>> Sam
>> In your org-babel-do-load-languages call, try to changing
>>     (sh . t)
>> to
>>     (shell . t)
>> --
>> Kyle
> I went ahead and tried that.  I still get that error.

I don't know what the underlying cause might be, but you might
be able to cure the symptom by doing

M-x load-library RET ob-core RET

which is where org-babel-get-header is defined. If that works,
then it's likely that a (require 'ob-core) is missing somewhere.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]