[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[O] Recent bug? in R source blocks generating images

From: William Denton
Subject: [O] Recent bug? in R source blocks generating images
Date: Thu, 7 Apr 2016 23:06:13 -0400 (EDT)
User-agent: Alpine 2.02 (DEB 1266 2009-07-14)

Sorry about that; hit send too soon.

There's something odd happening to me tonight with R source blocks and :session.

This works, and generates an image:

#+BEGIN_SRC R :results graphics :file example.png

But if I start an R session (M-x R) and then run this, with :session, I get an error.

#+BEGIN_SRC R :session :results graphics :file example.png

The error is

+ + Error: unexpected symbol in:
},error=function(e){plot(x=-1:1, y=-1:1, type='n"

That error= bit at the end looks related to my plot() example, but I don't think it is: the same error appears if I use ggplot2 (which is how I noticed it).

This is with Emacs and Org compiled from current source trees. It was working earlier this week, but I've updated since then. I refreshed everything (including R packages) and still get the error. I looked at the recent Org commits but don't see what might have done it, but I also don't think I'm doing anything wrong.

William Denton ↔  Toronto, Canada ↔  https://www.miskatonic.org/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]