[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] M-x cfw:open-org-calendar not working - Solved

From: Paul Harper
Subject: Re: [O] M-x cfw:open-org-calendar not working - Solved
Date: Wed, 27 Apr 2016 22:43:45 +0300

Can't remember where I got this from. But this config got Calfw and Org-gcal working with Gmail.

#+BEGIN_SRC emacs-lisp
(require 'calfw-cal)
(require 'calfw-ical)
(require 'calfw-howm)
(require 'calfw-org)

(defun my-open-calendar ()
    (cfw:org-create-source "Green")  ; orgmode source

;; Org-Gcal
(require 'org-gcal)
(setq org-gcal-client-id "mysecretclientid.googleusercontent.com"
      org-gcal-client-secret "myreallysecret"
      org-gcal-file-alist '(("address@hidden" .  

I hope it helps somebody out. 

On 27 April 2016 at 06:41, Paul Harper <address@hidden> wrote:

I am following this article "Taming Google Calendar With Org-Mode" to
try to get sync going with my Google
Calendar. http://jameswilliams.be/blog/2016/01/11/Taming-Your-GCal.html

I've installed Calfw and Org-Gcal with  the package manager. But when I
M-x cfw:open-org-calendar it does not find the command. Mx cf <tab> only
finds cfengine.

What is the best way for me to troubleshoot this? My setup is identical
to the article except for:

(add-to-list 'load-path "/home/username/.emacs.d/elpa/calfw-20160302.1858")
(require 'calfw)
(require 'calfw-org)


Sent with my mu4e




GnuPG Fingerprint: B3C2 6A80 BB3E 8D4D 126E  4FBE 5F62 4195 17D3 CB75

“Wisdom consists in being able to distinguish among dangers and make a choice of the least harmful.” — Niccolo Machiavelli, The Prince

“The user’s going to pick dancing pigs over security every time.” — Bruce Schneier

reply via email to

[Prev in Thread] Current Thread [Next in Thread]