[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] There is no line to end here at LaTeX org-ref export

From: Florian Lindner
Subject: Re: [O] There is no line to end here at LaTeX org-ref export
Date: Mon, 5 Sep 2016 22:55:40 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.2.0

Am 02.09.2016 um 15:12 schrieb Eric S Fraga:
> Can you post an actual org test file as an attachment?  And also the
> resulting LaTeX file on export?


sorry for the late reply. I tried to reproduce the problem firstly using emacs 
-Q but it worked like that.

After some bisect debugging I found out that setting

(setq org-latex-pdf-process '("latexmk -f -pdf %f"))

triggered the error.

But the usual latex process also causes the error, but gives the error message

Processing LaTeX file ./test2.tex...
PDF file produced with errors.

and continues. You have no errors using that snippet? Can you compile ther 
resulting tex file using auctex or the
latexmk command above? And why does latexmk -f does not continue despite the 
error? That's what the -f option should do?
I want to use latexmk to include also bibtex generation.

Ok, after some debugging and bisecting my .emacs, org-export-preserve-breaks t 
seems to cause the faulty export.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]