[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] There is no line to end here at LaTeX org-ref export

From: John Kitchin
Subject: Re: [O] There is no line to end here at LaTeX org-ref export
Date: Mon, 05 Sep 2016 17:34:01 -0400
User-agent: mu4e 0.9.16; emacs

that does explain why I couldn't reproduce what you see. I have
org-export-preserve-breaks set to nil. I didn't even know about that
one! Glad to hear you figured it out.

Florian Lindner writes:

> Am 02.09.2016 um 15:12 schrieb Eric S Fraga:
>> Can you post an actual org test file as an attachment?  And also the
>> resulting LaTeX file on export?
> Hey,
> sorry for the late reply. I tried to reproduce the problem firstly using 
> emacs -Q but it worked like that.
> After some bisect debugging I found out that setting
> (setq org-latex-pdf-process '("latexmk -f -pdf %f"))
> triggered the error.
> But the usual latex process also causes the error, but gives the error message
> Processing LaTeX file ./test2.tex...
> PDF file produced with errors.
> and continues. You have no errors using that snippet? Can you compile ther 
> resulting tex file using auctex or the
> latexmk command above? And why does latexmk -f does not continue despite the 
> error? That's what the -f option should do?
> I want to use latexmk to include also bibtex generation.
> Ok, after some debugging and bisecting my .emacs, org-export-preserve-breaks 
> t seems to cause the faulty export.
> Best,
> Florian

Professor John Kitchin
Doherty Hall A207F
Department of Chemical Engineering
Carnegie Mellon University
Pittsburgh, PA 15213

reply via email to

[Prev in Thread] Current Thread [Next in Thread]