[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Using Org and eev together - problem with source blocks

From: Eduardo Ochs
Subject: Using Org and eev together - problem with source blocks
Date: Sat, 9 Nov 2019 23:54:26 -0200

Hi list,

I gave a presentation about eev at the EmacsConf a few days ago, and
after the conference I started to work on a tutorial to explain how to
use Org and eev together... links:

  http://angg.twu.net/LATEX/2019emacsconf-long.pdf (slides)
  http://www.youtube.com/watch?v=86yiRG8YJD0&t=774 (demo)
  http://www.youtube.com/watch?v=86yiRG8YJD0&t=956 (demo: eepitch)
  http://angg.twu.net/eev-intros/find-org-intro.html (eev+Org, html)
  http://angg.twu.net/eev-intros/find-org-intro      (eev+Org, src)

I am longtime Org user that only uses a few features of Org - mainly
the ones here,

  (info "(org)Document Structure")

and when I tried to explain in my tutorial how to execute org source
blocks I stumbled on a behavior that I found very puzzling... I will
copy the relevant code here. The section on preparation says to run
these sexps,

  (require 'org)
  (require 'ob-sh)
  ;; or: (require 'ob-shell)
  (require 'ob-python)

and then a bit later the tutorial has this:

# (info "(org)Working With Source Code")
# (info "(org)Evaluating code blocks")

seq 200 204

#+BEGIN_SRC python
def square (x):
    return x*x


but when I run the shell block with C-c C-c I get these errors

  Error reading results: (user-error No table at point)
  Code block produced no output.

and an empty "#+RESULTS:" block in Emacs24, and the right results
block in some later versions of Emacs, and when I run the Python block
with C-c C-c I always get a results block like this (without the

  : None

What am I doing wrong? I expected an output of "25"... =(

Thanks in advance!

  Eduardo Ochs

reply via email to

[Prev in Thread] Current Thread [Next in Thread]