[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ESPResSo-users] Object in Fluid

From: Ivan Cimrak
Subject: Re: [ESPResSo-users] Object in Fluid
Date: Thu, 17 Jul 2014 13:10:39 +0200
User-agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

Dear Markus,

I put the scripts in the attachment. I just ran the simulation once again, and you can see the result on the video

soft_sphere was activated with parameters
inter 0 10 soft-sphere 0.0005 1.2 0.1 0.0

Maybe, when you used too weak soft_sphere (your parameter was 10^(-6) whereas mine was 10^(-4)), what happend was that the particles entered the boundary. But in that case you would have gotten different error message.

Markus, keep me please informed whether you can resolve this issue.


Dňa 17.7.2014 9:58 Wink, Markus wrote / napísal(a):
Dear Ivan,

thanks for your advice. I have tried to lower the factor a as you proposed. I 
used a = 5*10^-6 , corresponding to a force of f = 9.5*10^-4.
But still, the particle tears apart. Strange.
If you still got the script, which you ran and which worked, would you be so 
kind to send it to me, so I can check, if I made another stupid mistake?

Greetings and thanks a lot!


-----Ursprüngliche Nachricht-----
Von: Ivan Cimrak [mailto:address@hidden
Gesendet: Mittwoch, 16. Juli 2014 22:56
An: Wink, Markus
Cc: Andrew Jewett; address@hidden
Betreff: Re: [ESPResSo-users] Object in Fluid

Dear Markus,

The error message you have obtained indeed means that the bond of the object 
tears apart. The reason for this is that you have too strong soft_sphere 
potential. Your forces due to f_body are approximately 0.00156.

On the other hand, soft_sphere potential is given by V(r)=a/(r^n), the forces 
due to soft_sphere are thus F(r)=dV/dr=a*n/(r^{n+1}).
Now your soft_sphere potential starts to act at the distance 0.1 from the 
obstacle (your cut-off was 0.1) but this means that the particles immediately 
get the force of
1.0*1.2/(0.1^2.2) = 190.18  which is way too large. The system gets shock and 
then it blows apart.

I would suggest to set soft_sphere much lower, say e.g. a = 0.0005 (or even 
smaller). This results to force 0.0005*1.2/(0.1^2.2)=0.095 which is acceptable. 
I have tried this setting with smaller channel (for faster computations) and it 

Best regards,


On Wed, Jul 16, 2014 at 8:28 AM, Wink, Markus <address@hidden> wrote:
Dear all,

attached you will find pictures of the starting configuration and the 
configuration, when the simulation stops with the error message (actually 
Espresso is not cancelled, but no further integration step will be performed).

Looking forward to your answers.



-----Ursprüngliche Nachricht-----
Von: Andrew Jewett [mailto:address@hidden
Gesendet: Dienstag, 15. Juli 2014 17:59
An: Wink, Markus
Cc: address@hidden
Betreff: Re: [ESPResSo-users] Object in Fluid

Pictures can be helpful.
What does the system look like (at nearby times)?


On Tue, Jul 15, 2014 at 11:31 AM, Wink, Markus <address@hidden> wrote:
Dear all,

I tried to simulate the movement of a particle past an obstacle
inside a microfluidic channel using the oif method. At the moment I
am facing the problem, that, when the particle gets near the object,
the simulation stops and prints out the error message:

“broken: particles sum 2, id 0, partn 2, bond 2346”

I am not exactly sure, what that error message means. I guess, that
the bond of the object tears apart, so I could change the parameters of the 
Does anyone have a clue? For the potential between the particle and
the obstacle, I have chosen a soft sphere potential.

The files are attached.

Thanks a lot for your help.



Ivan Cimrak
FRI Zilinska Univerzita v Ziline
personal web:
cell-in-fluid group:

Ivan Cimrak
FRI Zilinska Univerzita v Ziline
personal web:
cell-in-fluid group:

Attachment: boundariesOK.tcl
Description: Text document

Attachment: scriptOK.tcl
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]