[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ESPResSo-users] Object in Fluid

From: Ivan Cimrak
Subject: Re: [ESPResSo-users] Object in Fluid
Date: Thu, 24 Jul 2014 10:32:31 +0200
User-agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

Dear Markus,

1. Now, I am not sure whether the setting agrid=1.0 solves your problem with the big simulation on one core. Does your simulation with box 22x50x27, agrid = 1 and a = 0.001 works fine?

2. When computing in parallel, you need to be sure that the splitting of your big domain generates local boxes of dimension compatible with agrid. Imagine you have large box 10x10x10 and you want to use 16 cores. One possible splitting is to divide x direction into two parts, y direction into 2 parts and z direction into 4 parts. This will divide large domain into 16 smaller parts. However, the dimension of smaller parts will be 5x5x2.5. And this is incompatible with agrid, since LB grid is one. Therefore in this particular case you may use 8 cores, which will divide large domain into 8 parts with dimensions 5x5x5.

There are variables in Espresso like local_box, min_global_cut, skin, and these variables (in addition to some other things) determine, how the domain is eventually split when running parallel. I wrote a short tutorial on this topic, see the attachment. I do not guarantee that the tutorial is 100% correct, however, it helps us to set the right values.

I hope this helps,

Dňa 24.7.2014 10:03 Wink, Markus wrote / napísal(a):
Dear Ivan,

I have checked the different configurations for a_grid (as you proposed in your 
last Email). If I change a_grid to 1, everything works just fine: the particle 
follows the stream lines of the fluid and passes the obstacle without any 
problems. But when I ran the original script I sent on July 15, I again get the 
error message (in both simulations the soft-sphere potential was chosen to have 
a factor a=0.001):
        broken: particles sum 2, id 0, partn 2, bond 2346
Afterwards, the no more integration steps are performed, although Espresso is 
still running (checked it using the top-command on the console). This I find 
very strange. The end configuration (when the error message occurs) you can 
find attached.

Another thing that bothers me concerns parallel computing using mpirun. I found 
out, that, depending on the box size I chose, it is possible, that Espresso 
escapes with the following error message:
        background_errors 0 {097 Lattice spacing agrid=1.000000 is incompatible with local_box_l[0]=5.500000 (box_l[0]=22.000000 node_grid[0]=4) 0.500000} 1 <consent> 2 <consent> 3 <consent> 4 <consent> 5 <consent> 6 <consent> 7 
<consent> 8 <consent> 9    <consent> 10 <consent> 11 <consent> 12 <consent> 13 <consent> 14 <consent> 15 <consent> 16 <consent> 17 <consent> 18 <consent> 19 <consent> 20 <consent> 
21 <consent> 22 <consent> 23 <consent> 24 <consent> 25 <consent> 26 <consent> 27   <consent> 28 <consent> 29 <consent> 30 <consent> 31 <consent>

The error message occurs with the following box size and the command "mpirun -n 
32" (my system provides 32 nodes I can run Espresso on):
        set width 20.
        set length 50.
        set height 27.
        # rectangular channel box geometry
        set boxX [expr $width+2]
        set boxY $length
        set boxZ [expr $height+2]
        setmd box_l $boxX $boxY $boxZ

If I run the simulation on only one node, I don't get that error message. So parallel 
computing discretizes the grid in some way (which I don't understand yet) and the a_grid 
(I chose agrid = 1) does not fit the node_grid. So I tried to have a look in the source 
code to find out, where "node_grid" is defined and to check, whether I can 
change it, but unfortunately I could not find it.
Does anyone have a clue and can help me out?



-----Ursprüngliche Nachricht-----
Von: Ivan Cimrak [mailto:address@hidden
Gesendet: Mittwoch, 23. Juli 2014 13:30
An: Wink, Markus
Cc: Andrew Jewett; address@hidden
Betreff: Re: AW: AW: [ESPResSo-users] Object in Fluid

Dear Markus,

I have noticed that you use agrid 0.5. This might be a problem although we do not know 
why. All our tests were run with agrid = 1 and all worked fine. This issue is on our 
"to do" list.

Regarding your questions: once you change agrid to 1, the simulation runs 
The big simulation, also, when I put agrid=1 to your first simulation, and I 
take a = 0.001 everything is perfect.

Can you check it?

What I find strange is that when I take your original code you sent on 15july, 
I change a to 0.001, then even with agrid=0.5 I don't get message with particle 
tearing apart. I attach the code.


Dňa 22.7.2014 13:47 Wink, Markus wrote / napísal(a):
Dear Ivan,

thanks for your help and for the nice video! I tried your script (with the 
configurations you chose, i. e. smaller channel for faster computation) and it 
worked fine. But still, I have some problems which I have no idea how to handle.

1) I tried a script with my geometry (which was bigger than yours) and 
different parameters for a:  a = 1, a = 0.1, a = 0.01, a = 0.0005, a= 0.00005, 
a= 0.000005. Still, I get the same error message, telling me, that my particle 
tears apart. This is quite strange, since at least for the configuration with 
the smallest a, the force acting on the particle by the obstacle is in the 
order of magnitude of the fluidic force.

So it seems, that the size of the object plays an important role for the 
stability of the simulation. I don't really understand, where the problem comes 
from, maybe you have an idea. And probably you also have an idea for my first 
question, why still the particle tears apart when reaching the obstacle, 
although I have changed the factor a to a very low value.

Greetings and thanks a lot,


Markus Wink
Fraunhofer ICT-IMM
Doktorand Abteilung Mikrofluidik und Analytik / Microfluidics and
Analytics Department Carl-Zeiss-Straße 18-20, 55129 Mainz, Germany
Phone +49 6131 990-396 / Fax +49 6131 990-205
address@hidden /

-----Ursprüngliche Nachricht-----
Von: Ivan Cimrak [mailto:address@hidden
Gesendet: Donnerstag, 17. Juli 2014 13:11
An: Wink, Markus
Cc: Andrew Jewett; address@hidden
Betreff: Re: AW: [ESPResSo-users] Object in Fluid

Dear Markus,

I put the scripts in the attachment. I just ran the simulation once
again, and you can see the result on the video

soft_sphere was activated with parameters inter 0 10 soft-sphere
0.0005 1.2 0.1 0.0

Maybe, when you used too weak soft_sphere (your parameter was 10^(-6) whereas 
mine was 10^(-4)), what happend was that the particles entered the boundary. 
But in that case you would have gotten different error message.

Markus, keep me please informed whether you can resolve this issue.


Dňa 17.7.2014 9:58 Wink, Markus wrote / napísal(a):
Dear Ivan,

thanks for your advice. I have tried to lower the factor a as you proposed. I 
used a = 5*10^-6 , corresponding to a force of f = 9.5*10^-4.
But still, the particle tears apart. Strange.
If you still got the script, which you ran and which worked, would you be so 
kind to send it to me, so I can check, if I made another stupid mistake?

Greetings and thanks a lot!


-----Ursprüngliche Nachricht-----
Von: Ivan Cimrak [mailto:address@hidden
Gesendet: Mittwoch, 16. Juli 2014 22:56
An: Wink, Markus
Cc: Andrew Jewett; address@hidden
Betreff: Re: [ESPResSo-users] Object in Fluid

Dear Markus,

The error message you have obtained indeed means that the bond of the object 
tears apart. The reason for this is that you have too strong soft_sphere 
potential. Your forces due to f_body are approximately 0.00156.

On the other hand, soft_sphere potential is given by V(r)=a/(r^n), the forces 
due to soft_sphere are thus F(r)=dV/dr=a*n/(r^{n+1}).
Now your soft_sphere potential starts to act at the distance 0.1 from
the obstacle (your cut-off was 0.1) but this means that the particles
immediately get the force of
1.0*1.2/(0.1^2.2) = 190.18  which is way too large. The system gets shock and 
then it blows apart.

I would suggest to set soft_sphere much lower, say e.g. a = 0.0005 (or even 
smaller). This results to force 0.0005*1.2/(0.1^2.2)=0.095 which is acceptable. 
I have tried this setting with smaller channel (for faster computations) and it 

Best regards,


On Wed, Jul 16, 2014 at 8:28 AM, Wink, Markus <address@hidden> wrote:
Dear all,

attached you will find pictures of the starting configuration and the 
configuration, when the simulation stops with the error message (actually 
Espresso is not cancelled, but no further integration step will be performed).

Looking forward to your answers.



-----Ursprüngliche Nachricht-----
Von: Andrew Jewett [mailto:address@hidden
Gesendet: Dienstag, 15. Juli 2014 17:59
An: Wink, Markus
Cc: address@hidden
Betreff: Re: [ESPResSo-users] Object in Fluid

Pictures can be helpful.
What does the system look like (at nearby times)?


On Tue, Jul 15, 2014 at 11:31 AM, Wink, Markus <address@hidden> wrote:
Dear all,

I tried to simulate the movement of a particle past an obstacle
inside a microfluidic channel using the oif method. At the moment I
am facing the problem, that, when the particle gets near the
object, the simulation stops and prints out the error message:

“broken: particles sum 2, id 0, partn 2, bond 2346”

I am not exactly sure, what that error message means. I guess, that
the bond of the object tears apart, so I could change the parameters of the 
Does anyone have a clue? For the potential between the particle and
the obstacle, I have chosen a soft sphere potential.

The files are attached.

Thanks a lot for your help.


Ivan Cimrak
FRI Zilinska Univerzita v Ziline
personal web:
cell-in-fluid group:
Ivan Cimrak
FRI Zilinska Univerzita v Ziline
personal web:
cell-in-fluid group:

Ivan Cimrak
FRI Zilinska Univerzita v Ziline
personal web:
cell-in-fluid group:

Ivan Cimrak
FRI Zilinska Univerzita v Ziline
personal web:
cell-in-fluid group:

Attachment: parallel simulations.docx
Description: application/vnd.openxmlformats-officedocument.wordprocessingml.document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]