[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[fluid-dev] Solved /dev/midi problem. but I think this needs documentati

From: Mikhail Ramendik
Subject: [fluid-dev] Solved /dev/midi problem. but I think this needs documentation
Date: 10 Apr 2003 00:42:07 +0400


On Wed, 2003-04-09 at 18:00, Mikhail Ramendik wrote:

> I have tryed to run fluidsynth-1.0.1 on my Linux system. But it said
> that there's no device /dev/midi .
> There indeed is none, but midi0, midi1, midi2, midi3, midi00, midi01,
> midi02, midi03 are present.
> I tried:
> ln -s /dev/midi0 /dev/midi
> but this did not help - fluidsynth still says that no device named
> /dev/midi is available.

Markus Nentwig from this list helped me solve the problem. First, it
turned out(via cat /dev/midi0) that /dev/midi0 was defunct, but
/dev/midi00 was working. Second, the following commandline led to a
working fluidsynth:

fluidsynth -m oss -o midi.oss.device="/dev/midi00" Soundfont.sf2

Thanks, Markus!

But the -o key is undocumented. I think this should get documented, as I
am not the only guy out there who has OSS drivers installed (it was in
the distro that way). Unfortunately, I can't submit a patch because I
don't exactly know what the -o key does, other than in this particular

Sincerely yours, Mikhail Ramendik

reply via email to

[Prev in Thread] Current Thread [Next in Thread]