[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[fluid-dev] FS produces unbearably loud noise when playing most instrume

From: kd4crel02
Subject: [fluid-dev] FS produces unbearably loud noise when playing most instruments, any soundfont
Date: 13 Jan 2005 05:26:08 -0000


Recently I got a MIDI interface and a keyboard, and I'm trying them out with 
FluidSynth to render the MIDI. For most soundfonts I've tried, the first piano 
instrument (bank 1, program 1) works fine. But when I try almost any other 
instrument and play a few notes, FluidSynth ends up producing a horrendously 
loud noise! The only way I can stop it is by changing to a new instrument. It's 
very weird.

It seems to happen most easily with instruments that don't naturally fade out 
when you hold them down, such as organs, accordions, cellos, and so on. I have 
one soundfont in which this happens for the first piano too, but for most 
soundfonts I can play the first piano without this bizarre behaviour.

As I said, I tried various soundfonts, and I haven't found one yet in which 
this doesn't happen. I tried fiddling around with FluidSynth's various audio 
and synth settings, but it made no difference. So it doesn't seem have to do 
with chorus, reverb, buffers, periods and so on. I even tried different audio 
output drivers, including oss, alsa, and jack, but the behaviour was the same.

The funny thing is, I don't remember this ever happening last year when I was 
using FluidSynth just to play MIDI files. It seemed to work like a charm back 
then - this noise thing never happened. But then I didn't have a MIDI keyboard 
hooked up, although I don't see how that could possibly make any difference 
with the sound synthesis.

Another thing that's different, however, is that I'm using kernel 2.6.10 now. 
Last time I used FluidSynth I was running kernel 2.4.26 or .27. Maybe 
something's changed between versions that's causing this weird thing to happen?

I might try recompiling FluidSynth or trying an older kernel. But has anyone 
else experienced such a thing?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]