[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] problems with fluidsynth 1.1.5 on a raspberry pi

From: Aere Greenway
Subject: Re: [fluid-dev] problems with fluidsynth 1.1.5 on a raspberry pi
Date: Fri, 12 Oct 2012 13:13:36 -0600


>From the error messages you get, it sounds like you don't have a security limits (/etc/security/limits.d) file set up to give your user-ID the necessary real-time priority, and the ability to lock memory. 

I have an even slower machine (450 megahertz) that runs Fluidsynth successfully (though it may have an FPU). 

Regardless, before putting in the security limits file, it would not successfully play anything but the most simple MIDI files (one part only). 

You need to create a file (whose name starts with your user-ID) in the following folder:  /etc/security/limits.d

For example, my user-ID is aere, so the filename I use is: aere.conf

The file needs to contain the following lines:

aere - rtprio 85
aere - memlock unlimited

Except, substitute your user-ID in place of "aere".  I'm pretty sure you need to re-boot (or at least sign-in again) after doing this.  You need to use the "sudo" command to write to the indicated folder. 

I really wish (where it is required for all but very fast machines) that when you install Fluidsynth (or Qsynth) it would do this configuration change for you, but alas, that is not currently the case. 

Also, beware of your machine's lack of memory.  The standard Fluidsynth font is nearly 150 megabytes just by itself.  I would think you would need to use a much smaller soundfont than what is normally used to make it work. 

- Aere

On Fri, 2012-10-12 at 19:59 +0200, Simon Eigeldinger wrote:
Hi all,

I am new to fluidsynth and i tried it to run it on my raspberry pi computer.
its a small ARM board with a 700 mhz processor and 256 mb ram.

When i tried it it played the file for a few seconds and then it strated 
to kind of grind or hum. sounded like a saw wave tone got quite low but 
went up and down the scale.

here's the output of the console:

$ fluidsynth -a alsa /usr/share/sounds/sf2/FluidR3_GM.sf2 10.mid

FluidSynth version 1.1.5
Copyright (C) 2000-2011 Peter Hanappe and others.
Distributed under the LGPL license.
SoundFont(R) is a registered trademark of E-mu Systems, Inc.

fluidsynth: warning: Failed to pin the sample data to RAM; swapping is 

Parameter '10.mid' not a SoundFont or MIDI file or error occurred 
identifying it
fluidsynth: warning: Requested a period size of 64, got 256 instead
Type 'help' for help topics.

fluidsynth: warning: Failed to set thread to high priority
fluidsynth: warning: Failed to set thread to high priority

Anyone knows thats wrong?
I also tried timidity but the annoying thing with it is that you have to 
create a channels configuration file first before you are able to use 
the soundfont.

Any help appreciated.

fluid-dev mailing list



reply via email to

[Prev in Thread] Current Thread [Next in Thread]