[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] Failure to bind server socket: 98

From: Marcus Weseloh
Subject: Re: [fluid-dev] Failure to bind server socket: 98
Date: Sun, 6 Mar 2022 23:34:41 +0100

Am So., 6. März 2022 um 19:31 Uhr schrieb Ben Gonzales via fluid-dev
> I start my FS server with the --no-shell option, then telnet in and out
> of the running server many times during a session with no problems. I am
> running RPi OS. I assume Marcus' example is starting with an active
> shell (without the --no-shell option)??

Yes, I see the problem when I start fluidsynth *with* interactive
shell and -s. When I type "quit" on the interactive shell, then
FluidSynth doesn't exit properly but waits for the server thread to
join(). The reason seems to be that the server thread is blocking in
the accept() call. Only if I telnet into the port (and therefore
trigger accept() to return) does FluidSynth actually exit. This
happens to me on Ubuntu 20.04 with FluidSynth compiled from the
current master.

> On 7/3/22 03:50, Ceresa Jean-Jacques wrote:
> > On Windows, with fluidynth v2.1.1 starting fluidsynth with -s and type
> > "quit", the program return correctly to the os command prompt.

I just tried it with 2.2.1 and got the same result: when I type
"quit", FluidSynth doesn't exit but waits for the accept() to return.
And I don't see any ifdefs for WIN32 around this call... really weird.
Is Windows handling thread joining differently and actually terminates
a thread blocking in IO when calling fluid_thread_join()?

> > Also, any remote command on the remote terminal talking with the
> > fluidsynth server works fine. The remote "quit" command works fine too.

Yes, that works for me as well. But I do understand Bens request for a
new command that actually terminates the whole FluidSynth server and
not just the current telnet shell. Maybe we could implement a
"shutdown" command?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]