[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ft-devel] freetype utils - how do I compile them?

From: ajaxas
Subject: Re: [ft-devel] freetype utils - how do I compile them?
Date: Sun, 5 Aug 2007 22:17:53 +0700

On Sun, 05 Aug 2007 07:39:59 +0200 (CEST)
Werner LEMBERG <address@hidden> wrote:

> > 1. I checkout-ed ft2demos CVS module as you told me to. But, after I
> > ran 'make' I couldn't 'make install' it. So I decided to run ftview
> > from the [makedir]/bin/.
> This is intentional.  Those demo programs are really just for testing
> FreeType and have no other specific use.  On the other hand, almost
> all distributions seem to provide packages for them.  Hmmm.  In case
> someone provides patches for an `install' target, I'll gladly add them
> to CVS.

Not me, I won't be able to write a string of code to save my life...
> > 2. after I ran ../ft2demos/bin/ftview, it threw off the error
> > message I cited. I gave it the correct path to the font file, and it
> > worked.
> ???  Did it work now or not?

ftview -r 100 -m 'some text' 14 tahoma.ttf - didn't work,
ftview -r 100 -m 'some text' 14 /home/ajaxas/.fonts/tahoma.ttf - did work.
> > 3. ftview can't show me Cyrillic symbols, just abracadabra.
> Command line option `-e unic' should give access to a Unicode cmap.
> Or do you mean something else?

address@hidden:~$ ftview -r 100 -m 'русские буквы Т Т Т' 14 
/home/ajaxas/.fonts/tahoma.ttf -e unic

=> see attached image.

ajaxas <address@hidden>

Attachment: Screenshot_02.png
Description: PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]