[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Geiser-users] geiser-xref-callers does not seem to work

From: Jose A. Ortega Ruiz
Subject: Re: [Geiser-users] geiser-xref-callers does not seem to work
Date: Mon, 26 Feb 2018 12:39:31 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.91 (gnu/linux)

On Mon, Feb 26 2018, Chris Marusich wrote:

> Hi Jose,
> This is a follow-up to the following threads, about geiser-xref-callers
> not working:
> I've tried the latest Geiser version (commit
> e1603edd6f64094495af34432f0d9be621173403), and geiser-xref-callers now
> works.  This is awesome!  Thank you for fixing it.
> However, it does not seem to find every call site .  For example, if you
> place point on the definition of the procedure qemu-image in
> gnu/system/vm.scm in the Guix source [1], and then you press C-c <, it
> will find no callers even though there are callers in the same file.
> Is the reason that geiser-xref-callers cannot find the callers of
> qemu-image because geiser-xref-callers is still not working correctly?
> Or could it be because the callers are somehow obfuscated in a way that
> makes it difficult for geiser-xref-callers to find them?

geiser-xref-callers (as most geiser functions), work by asking the guile
process for the callers, so it's unlikely syntactic obfuscation is an
issue directly.  but maybe some sort of delayed evaluation could play a
role, i am not sure.  just to make sure (i guess i already asked this in
those threads), you have loaded the module in your running REPL process
(e.g., with C-c C-k in the buffer), right?

if so, a way to look for more info is to enable full traces in geiser
with C-u M-x geiser-show-log, and see what pops up in the message's
buffer when you try the callers command.

Right now I'm having amnesia and deja vu at the same time. I think I've
forgotten this before. -Steven Wright, comedian (b. 1955)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]