[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Getfem-users] Generic Bricks definition using gf_asm.

From: Nicolò Cambiaso
Subject: [Getfem-users] Generic Bricks definition using gf_asm.
Date: Mon, 30 Sep 2019 12:25:51 +0200

Dear users,
I would like to solve a system of equations using Getfemm++ with Matlab interface.
So I created a block matrix, and now i cannot create the corresponding bricks.
I'm using the command "gf_asm", hoping it's the correct one.

the block is the following:
Mtt=1/k u_t v_t. (v_t is the test function corresponding to u_t)
in full despair, i also removed the 1/k therm, and still nothing worked. this is what i wrote:

gf_asm('generic', mim3, 2, 'Grad_Test2_ut.Grad_Test_ut', -1, 'ut',1, U);

And the error message is:

"Error using gf_matlab
Error in, line 9519 void getfem::ga_node_analysis(const string&, getfem::ga_tree&, const
getfem::ga_workspace&, getfem::pga_tree_node, bgeot::size_type, bgeot::size_type, bool, bool, int):
Error in assembly string

Error in gf_asm (line 338)
    [varargout{1:nargout}]=gf_matlab('asm', varargin{:});

Error in Comeon (line 56)
Mtt=gf_asm('generic', mim3, 2, 'Grad_Test2_ut.Grad_Test_ut', -1, 'ut',1, U);  % M_tt, proviamo"

mim3= gf_mesh_im( mf3, gf_integ('IM_NC(3,1)') )
OmegaM=gf_mesh('regular simplices',vectX, vectY, vectZ, 'degree', 1)

at his point, i defined U as ones(2,2,2,3), having the vectX(/Y/Z) only 2 points each one, for now, and because u_t is a 3D vector.
I think that's not correct, but i have no idea of the correct dimension of U, and i tried everything that came to my mind ... and still nothing worked.

I found a lot of material dealing with this on c++ interface, but unfortunately I cannot male it work in Matlab.

thank you very much,
Nicolo Cambiaso.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]