[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gforth] GForth on Raspberry Pi - Serial port

From: Mario Beaulieu
Subject: [gforth] GForth on Raspberry Pi - Serial port
Date: Wed, 12 Aug 2015 09:19:40 -0400


I installed GForth on my Raspberry Pi (Linux, ARM). I have difficulty when I 
try to access the serial port.

First, I tried to include "Serial.fs" from the "contrib" directory. It gave me 
an error because it could not find the word "ioctl". After some research, I 
found it in "Syscalls386.fs". 
So I included it too, but syscalls could not find the word ".d" which is in 
assembler. I found it in "asm.fs" in the "/arch/386" directory. Note that ".d" 
is not defined in "asm.fs" in the "/arch/ARM" directory, which would have been 
my first choice since that's the processor I'm working on.
I also had to include "strings.fs" eventually.

So I managed to compile without error, but when I run it (serial_open), I get 
an error "609: instruction not allowed" (translated from French - instruction 
non permise). 

I suspect that I'm not including the right files.

Is syscalls386 supposed to work on an ARM architecture or is it only for x86?
Am I using the right files?

What am I doing wrong?



Envoyé de mon iPad

reply via email to

[Prev in Thread] Current Thread [Next in Thread]