[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Trouble using Gforth, having installed via homebrew on OSX

From: Alex Byrne
Subject: Trouble using Gforth, having installed via homebrew on OSX
Date: Mon, 25 Jul 2022 15:30:11 +0100

I'm new to forth, and in fact low level programming entirely. I think the
language is neat, but using it is so far another matter! I've just
installed (ostensibly successfully) gforth 0.7.3 on a macOS 12.4 montery
apple m1 pro via homebrew. Unfortunately, I think the path is misconfigured
and I'm struggling to rectify it.

% gforth


gforth: cannot open image file in path
for reading

It can't find the image. And echo $GFORTHPATH returns empty. So, I tried

% GFORTHPATH=/opt/homebrew/Cellar/gforth/0.7.3_3/lib/gforth/0.7.3
% exporth GFORTHPATH
% gforth

Which works, but isn't persistent across terminal instances.

I read that fixpath.fs might be relevant, and so tried to use that, but

% gforth fixpath.fs $GFORTHPATH gforth

Fixing gforth with

in file included from *OS command line*:-1
No such file or directory
2 arg >>>fix-exe<<<
$129842DE0 throw

even though that file does exist at that path. Not sure where to go from


reply via email to

[Prev in Thread] Current Thread [Next in Thread]