[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trouble using Gforth, having installed via homebrew on OSX

From: Alex Byrne
Subject: Re: Trouble using Gforth, having installed via homebrew on OSX
Date: Mon, 25 Jul 2022 21:27:43 +0100

Putting it in ~/.bashrc makes it persistent but doesn't solve the subsquent
issue of quote:

I read that fixpath.fs might be relevant, and so tried to use that, but

% gforth fixpath.fs $GFORTHPATH gforth

Fixing gforth with

in file included from *OS command line*:-1
No such file or directory
2 arg >>>fix-exe<<<
$129842DE0 throw

even though that file does exist at that path.


This implies to me that there is something further wrong, and I don't
really want to get half way into a project and then start fighting with
some installation issues.

On Mon, Jul 25, 2022 at 6:39 PM Will Mengarini <> wrote:

> * Bernd Paysan <> [22-07/25=Mo 19:16 +0200]:
> > Am Montag, 25. Juli 2022, 16:30:11 CEST schrieb Alex Byrne:
> >> It can't find the image.  And echo $GFORTHPATH
> >> returns empty.  So, I tried instead:
> >>
> >> % GFORTHPATH=/opt/homebrew/Cellar/gforth/0.7.3_3/lib/gforth/0.7.3
> >> % exporth GFORTHPATH
> >>
> >> Which works, but isn't persistent across terminal instances.
> >
> > You can put that into your ~/.bashrc,
> > then it is persistent across instances.
> Also, "export GFORTHPATH", not "exporth GFORTHPATH".

reply via email to

[Prev in Thread] Current Thread [Next in Thread]