[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-dev] Re: 0.8.3 not building on Fedora 6 (Russ Nelson)

From: zou lunkai
Subject: [Gnash-dev] Re: 0.8.3 not building on Fedora 6 (Russ Nelson)
Date: Sat, 7 Jun 2008 09:53:09 +0800

We would still like Gnash to work on Fedora6 if possible.  The failure
was due to compiler bugs(GCC 4.3).  But GCC4.3 is not too old at all.
And I am sure some older compilers are still in use in many platforms.
The building bug on Fedora6 should be eliminated by more carefull
coding in a long-term plan.


On 6/6/08, zou lunkai <address@hidden> wrote:
> >`.L2441' referenced in section
> >`.gnu.linkonce.r._ZNSt6vectorIN5gnash8as_valueESaIS1_EE13_M_insert_auxEN9__gnu
> >_cxx17__normal_iteratorIPS1_S3_EERKS1_' of .libs/PropertyList.o: defined in
> >discarded section
> >`.gnu.linkonce.t._ZNSt6vectorIN5gnash8as_valueESaIS1_EE13_M_insert_auxEN9__gnu
> >_cxx17__normal_iteratorIPS1_S3_EERKS1_' of .libs/PropertyList.o
> >Any advice?  Anybody seen this before?  Know how to fix it?
> I'v seen this ".gnu.linkonce" failure on my Fedora6 system many times,
> and also fixed it many times.
> The general solution from google is upgrading or downgrading the
> bin_utilites, which is not a nice way to me.
> My fixing was to drop some unnecessay empty inlined dtors or ctors
> from the source code. This always worked for me. Just that you don't
> have much clue which dtor/ctor is the culprit.
> Also, compiling with -O0 could workaround the problem.
> I am tired of fixing this annoying problem now, so most of the times,
> I just work on another Federa 5 machine.
> --zou

reply via email to

[Prev in Thread] Current Thread [Next in Thread]