[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re[2]: [Gnash-dev] Building Gnash for the TDS/Trimble Nomad

From: Udo Giacomozzi
Subject: Re[2]: [Gnash-dev] Building Gnash for the TDS/Trimble Nomad
Date: Thu, 10 Sep 2009 16:02:34 +0200

Hello Rob,

Wednesday, September 9, 2009, 9:54:21 PM, you wrote:
>> Last time I tried this, it worked well if you do NOT include any media
>> handler, but that is what I'm trying to do right now (to have audio
>> support).

RS>    Good luck. From looking through the Nomad SDK, Gstreamer appears to
RS> be only partially installed. You might have better luck with ffmpeg 
RS> directly.

Whatever is easier. I think I ran into other problems trying ffmpeg
(can't remember which, exactly).

>> In the meantime there is a newer one, which I'm testing right now:
RS>    I used the newer one, with my changes.

IMHO you should not need this particular archive at all, since it's
QTExtended-related. The main SDK is another one (mentioned in my other

>> The Nomad comes with an (old) GST pre-installed, but some other libs
>> are missing. I downloaded and built them separately (for running Gnash
>> I put the .so files in the same directory, for simplicity):
RS>    Which I cleaned up an reorganized to work the standard way. The 
RS> improved sysroot that successfully builds Gnash is at:

Can you tell me exactly which modifications you made? So I can let the
people at SDG Systems know...

RS> ../trunk/configure
RS> --with-top-level=/opt/sdg/angstrom2007.12/sdk/arm-angstrom-linux-gnueabi
RS> --host=arm-angstrom-linux-gnueabi --build=i686-pc-linux-gnu 
RS> --enable-gui=fb --enable-extensions=fileio.

I prefer not to mix up the original SDK with "my own" libs and so keep
them in a separate place together with Gnash. Same applies for the
firmware on the device. We try to avoid much changes of the original
firmware and just add our own software (that's why Gnash and all of
it's required libs are stored together in one directory). Otherwise it
becomes difficult to keep a number of physical devices up to date..

>> Currently some manual patches are necessary to help building Gnash
>> (current trunk). Bug reports are files for this.

RS>    All fixed in trunk as of revno # 11502.


RS> The other problem was the Gstreamer headers wanted
RS> libxml2 headers, which we don't look for.

That's why I use

>> Without --enable-media=gst this produced a working Gnash build for the
>> Nomad, altough this was some months ago.

RS>    My newer build is at: 
RS> This is trunk as
RS> of revno #11502. I don't have any Nomad hardware, so I can't test it. 
RS> (add begging for cool hardware here... :-) )

Perhaps you could get in touch with Todd Blumer, President of SDG
Systems. He showed interest into my efforts to bring Gnash to the
Please be aware that they just do the Linux port, while the hardware
is built by Trimble (and comes with Windows).
Also have a look at this new hardware:

I did a fresh bzr checkout into a empty directory and tried to build
Gnash (same configure options as last time).

It fails with a bunch of error messages right at the beginning:

 arm-angstrom-linux-gnueabi-g++ -DHAVE_CONFIG_H -I. -I..
-DSYSCONFDIR=\"/usr/local/etc\" -I../libnet -I../libamf -I../libcore
-I../libcore/swf -pthread
-g -O2 -pthread -W -Wall -Wcast-align -Wcast-qual -Wpointer-arith
-Wreturn-type -Wnon-virtual-dtor -Wunused -fvisibility-inlines-hidden
-MT libgnashbase_la-extension.lo -MD -MP -MF
.deps/libgnashbase_la-extension.Tpo -c extension.cpp  -fPIC -DPIC -o
In file included from rc.h:26,
                 from log.h:25,
                 from extension.cpp:43:
../libcore/StringPredicates.h:24:46: error: boost/algorithm/string/compare.hpp: 
No such file or directory
../libcore/StringPredicates.h:25:48: error: 
boost/algorithm/string/predicate.hpp: No such file or directory
In file included from log.h:25,
                 from extension.cpp:43:
rc.h:32:29: error: boost/cstdint.hpp: No such file or directory
rc.h:33:31: error: boost/tokenizer.hpp: No such file or directory


Apparently the boost libs are not included. I had the same problem
with my earlier build (see bug #26115) and solved it the same way:

  cd libcore && ln -s ../../../boost_1_38_0/boost && cd ..

I could successfully build Gnash *without* any modifications to the

Gnash runs now. I've got no audio so far, but that's because GST
cannot find the required plugins for audio/mpeg.

Thanks, Rob, you saved my day :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]